Tecma Marine Toilet Noise

The friendliest place on the web for anyone who enjoys boating.
If you have answers, please help by responding to the unanswered posts.

markroper

Newbie
Joined
May 20, 2024
Messages
1
Location
Broadbeach Waters
Hi guys,

Wondering if anyone had any suggestions for this issue?

When I flush my 24v Tecma toilet (single flush and expel system), as the bowl is filling with water, a groaning sound is heard in the pipes, almost like a rapid knocking noise.
to complicate things further, it can be stopped by turning on the HOT water tap in my bathroom sink near one of the toilets (2 toilets on the boat, and sound is made when either one is flushed). The problem still exists when I turn on the cold water though. Noise is only on filling the bowl, not expelling the water, so the macerator isn't the problem. And the sound is not generated from the head itself, but in the pipes under the floor somewhere.

Sorry for the vague description, but it is a rather unusual problem that I haven't heard of or seen before.

Any suggestions or hints to troubleshoot this?

Cheers
 
In houses you can get noise from plumbing pipes that are not secured. Doesn’t really sound like a groan but maybe something to check. Strange problem. I am not familiar at all with this head.
 
Hi guys,

Wondering if anyone had any suggestions for this issue?

When I flush my 24v Tecma toilet (single flush and expel system), as the bowl is filling with water, a groaning sound is heard in the pipes, almost like a rapid knocking noise.
to complicate things further, it can be stopped by turning on the HOT water tap in my bathroom sink near one of the toilets (2 toilets on the boat, and sound is made when either one is flushed). The problem still exists when I turn on the cold water though. Noise is only on filling the bowl, not expelling the water, so the macerator isn't the problem. And the sound is not generated from the head itself, but in the pipes under the floor somewhere.

Sorry for the vague description, but it is a rather unusual problem that I haven't heard of or seen before.

Any suggestions or hints to troubleshoot this?

Cheers
Do you have an expansion tank in the system? Of not, add a small one. The issue doesn't sound like it has anything to do with the head itself.
 
Back
Top Bottom