Reply
 
Thread Tools Search this Thread Display Modes
 
Old 01-22-2019, 12:26 AM   #1
Senior Member
 
Restitution's Avatar
 
City: Kalama, WA
Country: USA
Vessel Name: "Restitution"
Vessel Model: 38' Californian
Join Date: Mar 2012
Posts: 177
Espar D7L advice needed

Once again, fuse issue on Espar D7L heater. Good start up, runs for 15 to 20 minutes, then 8 amp “Volkswagen” type fuse blows as pictured. What corrective action should I try to take?
Attached Thumbnails
Click image for larger version

Name:	5698BB86-AE65-494A-8F17-9148F6D3B373.jpg
Views:	20
Size:	105.7 KB
ID:	84512  
__________________
Advertisement

Restitution is offline   Reply With Quote
Old 01-22-2019, 12:45 AM   #2
Veteran Member
 
Spinner's Avatar
 
City: Seattle
Country: USA
Vessel Name: Spinner
Vessel Model: 2003 Nordic Tug 42
Join Date: Dec 2018
Posts: 62
Check the pumps! My Espar worked, sort of, when I bought the boat last February. Naturally, shortly before my first long cruise, it stopped working for more than a few minutes, and then would not start at all. The diagnosis and pinholes in one of the two pump diaphragms. Had to have both pumps replaced (I think the problem with one caused the failure in the other pump).
__________________
Regards

Sue
42 Nordic Tug Spinner
Spinner is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off





All times are GMT -5. The time now is 10:46 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2006 - 2012