ST60 speed transducer maintenance

The friendliest place on the web for anyone who enjoys boating.
If you have answers, please help by responding to the unanswered posts.

NWboater2

Senior Member
Joined
Apr 28, 2021
Messages
124
Vessel Name
Ripple
Vessel Make
2005 Grand Banks 42 EU
Hi all — lotsa people working on their boats this weekend! My 05 GB 42 electronics are partly original— raymarine ST60 autopilot, wind temp and speed transducers… the speed thru the water display recently stopped showing any speed and no it longer keeps the log.
So after I convinced myself I could do it, I tried to replace the old transducer with the plug so I could clean it.

The “hand tighten” ring was on stronger than my hands, so I got a strap wrench and got it right off. Got ready to do the swap, wife dialed 91- and …. Could not get the old one out. Absolutely glued in.
I suppose can wait til I haul next year but any tips on how to remove, in the water?? The structure is bronze, the guts are plastic…So I’m less likely to break the through hull.
Oh — last hauled year ago, and have a diver coming ( not for this) so maybe he can help clean from outside. Thoughts? Thanks!
 
When I had mine changed they cut another hole. I don't know if that is a standard or shade tree fix. Your diver might be able to help, if nothing else he will have strong hands.
 
Thanks bump.
My post wasn't very clear, which is probably why it lived on the “no responses yet” list. Sorry

This is a retractable thru hull speed and temp transducer, with a little paddle wheel. Purely for Speed thru the water, not depth. Not critical but useful.

It is designed to be serviced in the water — you unscrew the ring cap, pull it out, and quickly put in the nearby, blank, same-shaped plug, and clean the main, wired, smart one’s paddle wheel before swapping them back out. They even sell a kit w new wheel and axle and o rings. It has a little valve/flap that supposedly minimizes the water inflow.

But Mine seems to be really stuck in the hole. I would not cut a whole new hole in the hull to replace; I’d abandon it first, or more likely wait til next haul out and pound it up into the boat from the outside, even if I damage it and have to get a new unit (new models apparently fit in same 2 inch bronze thru hull, and the wires can be spliced ).
The Diver came when I wasn’t there and cleaned growth but I haven’t tried to pull it again. Might tho. Thanks!
 
It's probably merely glued in place by marine growth. I've always pulled and cleaned mine twice per season and it generally needs a bit more of a tug after the second half of the season.
I would expect that with a diver adding a bit of percussion from beneath it would yield.

Unless... have you EVER had it out? is it possible that a previous owner ignorantly glued it in place with some sort of sealant?

and yes, when you pull it there will be a dramatic geyser of water. The plug will go in fairly easily, but a bit of vaseline on the o-ring is probably a good idea as well.
 
Back
Top Bottom