View Single Post
Old 06-07-2020, 10:42 AM   #41
Martin J
Martin J's Avatar
City: Mt Crested Butte
Vessel Name: Artemis
Vessel Model: Cheoy Lee 67
Join Date: Feb 2013
Posts: 539
Had a similar thing a few weeks ago, on a relatively new installation (6 months old). Screen would show info but unit would not work and then the screen shows no info etc. Checked all my battery terminals etc, a real head scratcher, Magnum inverter. Pressing the reboot button would not solve or work . Disconnected Neg terminal on battery bank. still no success checked voltage through system all showed good. Then by chance when checking the voltage behind the battery switch, we found intermittent voltage on the outlet side of the battery switch. Removed switch and found loose nut/cable, tightened the nut and now everything works fine. The whole problem revolved on not torqueing the battery switch terminal properly during the install. After previously connecting the battery switch during the install, the electrician then screwed it to the bulkhead twisting it slightly causing the nut cable to unscrew slightly. Worked for 6 months and then one supposes a slight corrosion on the loose terminals and that was that.
Martin J is offline   Reply With Quote