Reply
 
Thread Tools Search this Thread Display Modes
 
Old 05-05-2014, 07:07 AM   #1
Guru
 
fryedaze's Avatar
 
City: Solomons Island Md
Vessel Name: Fryedaze
Vessel Model: MC 42 (Overseas Co) Monk 42
Join Date: Sep 2011
Posts: 1,566
Raymarine ST7000 Autohelm failed

My ST7000 display/controller on the bridge went blank. The lower helm ST6000 unit works fine. I checked the voltages on the pins to the seatalk connection to the ST7000 and they are the same as the ST6000. So it looks like a problem with the ST7000 unit.
Does anyone have any experience or ideas of repair/replacement strategy?
__________________
Dave Frye
Fryedaze, MC 42 (Monk 42') 1989 Overseas Co
https://mvfryedaze.blogspot.com/
fryedaze is offline   Reply With Quote
Old 05-05-2014, 10:11 AM   #2
Senior Member
 
SteveH's Avatar
 
City: Western WA
Join Date: Oct 2007
Posts: 110
Have you tried powering down everything, then cleaning the contacts at both the SeaTalk switch and at the AP unit then reconnecting everything? With all the issues I've had with my Raymarine system, cleaning the contacts works 9 times out of ten.

SteveH
SteveH is offline   Reply With Quote
Old 05-05-2014, 12:19 PM   #3
Guru
 
fryedaze's Avatar
 
City: Solomons Island Md
Vessel Name: Fryedaze
Vessel Model: MC 42 (Overseas Co) Monk 42
Join Date: Sep 2011
Posts: 1,566
Quote:
Originally Posted by SteveH View Post
Have you tried powering down everything, then cleaning the contacts at both the SeaTalk switch and at the AP unit then reconnecting everything? With all the issues I've had with my Raymarine system, cleaning the contacts works 9 times out of ten.

SteveH
I have good signal to the unit as measured on the three pin connector at the unit.
__________________
Dave Frye
Fryedaze, MC 42 (Monk 42') 1989 Overseas Co
https://mvfryedaze.blogspot.com/
fryedaze is offline   Reply With Quote
Old 05-05-2014, 05:24 PM   #4
Senior Member
 
Baggiolini's Avatar
 
City: Monterey, CA
Vessel Name: Mahalo
Vessel Model: Defever 44
Join Date: Jun 2011
Posts: 405
I bought a new display on ebay for $350 +- when mine died. Another issue was resolved when I located a corroded splice in the engine room.
Baggiolini is offline   Reply With Quote
Old 05-05-2014, 08:41 PM   #5
Guru
 
fryedaze's Avatar
 
City: Solomons Island Md
Vessel Name: Fryedaze
Vessel Model: MC 42 (Overseas Co) Monk 42
Join Date: Sep 2011
Posts: 1,566
Quote:
Originally Posted by Baggiolini View Post
I bought a new display on ebay for $350 +- when mine died. Another issue was resolved when I located a corroded splice in the engine room.
It looks like that is the path I am taking. $350 for an ebay refurbished unit with new LCD screen and then a $100 refund if you turn in your old unit.
__________________
Dave Frye
Fryedaze, MC 42 (Monk 42') 1989 Overseas Co
https://mvfryedaze.blogspot.com/
fryedaze is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Trawler Port Captains
Port Captains are TF volunteers who can serve as local guides or assist with local arrangements and information. Search below to locate Port Captains near your destination. To learn more about this program read here: TF Port Captain Program





All times are GMT -5. The time now is 07:05 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2006 - 2012