Trawler Forum

Trawler Forum (https://www.trawlerforum.com/forums/)
-   Welcome Mat (https://www.trawlerforum.com/forums/s53/)
-   -   Vermont Marine Trader 38 w/bad Perkins T6354 (https://www.trawlerforum.com/forums/s53/vermont-marine-trader-38-w-bad-perkins-t6354-33194.html)

bustedbelt 07-25-2017 01:22 PM

Vermont Marine Trader 38 w/bad Perkins T6354
 
Hey everyone, I am happy to have access to the info on this forum, as last year I bought a 38' Marine Trader with Perkins T6354 Range 4 240HP (I think) motors - one is good (enough). The other motor is locked up. Many of my questions will be about rehabbing the bad motor. So far I've discovered that we drove the boat from south of Boston to Lake Champlain without the turbo spinning! And that the two motors have different turbos! Wow. It's a journey. Thanks in advance for all the help.

Bill

alormaria 07-25-2017 02:45 PM

If you have gone that far why change it? I know people with good motors that haven't gotten that far.

RT Firefly 07-25-2017 02:58 PM

Greetings,
Welcome aboard.

bustedbelt 07-25-2017 03:16 PM

Quote:

Originally Posted by alormaria (Post 576609)
If you have gone that far why change it? I know people with good motors that haven't gotten that far.

I am leaving the good motor for now. I am working on the bad one.

Donna 07-25-2017 09:09 PM

Are those original engines? Haven't heard of Marine Trader using Perkins? Oh, and welcome aboard!


All times are GMT -5. The time now is 02:34 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2006 - 2012