Reply
 
Thread Tools Search this Thread Display Modes
 
Old 06-10-2017, 04:04 PM   #1
Newbie
 
City: Sidney, BC
Country: Canada & St Pete FL USA
Vessel Name: @Westerly
Vessel Model: 1978 Grand Banks 42 Classic
Join Date: May 2008
Posts: 4
Tach Sending unit for old Ford Lehman 120

Forum

I would like to request a bid of help. I have a 1978 Grand Banks 42 Classic with 120 hp Ford Lehman engines.

My problem is that one of the tachometer sending units has failed and there does not appear to be any available. I know I should bite the bullet and replace all the tachometers and pick up the digital signal from my alternators.

But, I would like to keep original tachs if possible. Is there any chance you know where I can get a new or working used old school sending unit? I believe these sending units were used for years, so I was just hoping to find one laying in a spare parts bin or from an engine that has been parted out.

The markings on it are:

ID #? 667SK followed by 1.000 and underneath w11. Iíve also attached a couple of pictures of the unit.

Any assistance you could provide on this quest is greatly appreciated. If you find one, please contact me and Iíll arrange payment and shipping.

Thank you

Drew
@Westerly
__________________
Advertisement

dlippert is offline   Reply With Quote
Old 06-10-2017, 04:25 PM   #2
Enigma
 
RT Firefly's Avatar
 
City: Slicker?
Country: Bumpkin?
Join Date: Oct 2007
Posts: 10,801
Ummm....no pictures...
__________________

__________________
RTF
RT Firefly is offline   Reply With Quote
Old 06-10-2017, 04:33 PM   #3
TF Site Team
 
Larry M's Avatar
 
City: JAX, FL
Country: USA
Vessel Name: Hobo
Vessel Model: Krogen 42-120
Join Date: Nov 2008
Posts: 6,562
Try these guys. I've bought parts for my VDO hour meters from them. They also list repair shops on their web site.

Odometer Gears - WELCOME
Larry M is offline   Reply With Quote
Old 06-10-2017, 09:13 PM   #4
Newbie
 
City: Sidney, BC
Country: Canada & St Pete FL USA
Vessel Name: @Westerly
Vessel Model: 1978 Grand Banks 42 Classic
Join Date: May 2008
Posts: 4
I did attach.. but obviously it didn't work.. will try again.

Figured it out.. have to hit Upload

thanks
Attached Images
  
dlippert is offline   Reply With Quote
Old 06-13-2017, 05:32 PM   #5
ljk
Senior Member
 
ljk's Avatar
 
City: Cape Coral and Marathon FL
Country: USA
Vessel Name: Chardonnay
Vessel Model: 34 Mainship Pilot
Join Date: Jul 2013
Posts: 124
Bob Smiths Company

Did you try calling Bob Smiths company in VA? He passed but last I heard company was still in business. Called American Diesel I think? They specialize in the Lehmans.
ljk is offline   Reply With Quote
Old 06-13-2017, 11:30 PM   #6
Guru
 
dhmeissner's Avatar
 
City: Port Townsend
Country: North America
Vessel Name: The Promise
Vessel Model: Roughwater 35
Join Date: Sep 2012
Posts: 1,533
http://www.aetnaengineering.com/wp-c...ve-Adapter.pdf

https://www.fisheriessupply.com/aetn...rs-and-sensors
__________________
Dave & Suzie - Roughwater 35
http://thepromiserwb1029.org/2012/09...the-promise-2/
dhmeissner is offline   Reply With Quote
Old 06-15-2017, 08:40 PM   #7
Member
 
City: Annapolis
Country: USA
Vessel Name: Berto
Vessel Model: Grand Banks 42
Join Date: Feb 2017
Posts: 7
Call Brian at American Diesel.
RB58 is offline   Reply With Quote
Old 06-17-2017, 02:38 PM   #8
Guru
 
Daddyo's Avatar


 
City: Cruising East Coast US
Country: USA
Vessel Name: Grace
Vessel Model: DeFever 48
Join Date: Apr 2008
Posts: 2,456
Bob Smith passed away ?? :-( All of my 120s sent to the tachs from the alternator.
__________________
Mark Bowerman
Brokerage owner and cruiser
Esse Quam Videri
http://graceyachting.com/
Daddyo is offline   Reply With Quote
Old 06-17-2017, 02:50 PM   #9
Senior Member
 
catalinajack's Avatar
 
City: Edgewater, MD
Country: USA
Vessel Name: Catalina Jack
Vessel Model: Defever 44
Join Date: Nov 2011
Posts: 474
Quote:
Originally Posted by Daddyo View Post
Bob Smith passed away ?? :-( All of my 120s sent to the tachs from the alternator.
I replaced all four on my tachs on my two Lehman 120's. Used VDO's on the lower and IssPro's on the upper helm. I used the original alternator signals. After adjusting (very easy process on both), they are spot-on as compared to an optical reading at the engines. Those old Motorolas were never very good even when new.
catalinajack is offline   Reply With Quote
Old 06-17-2017, 03:20 PM   #10
Guru
 
Irish Rambler's Avatar
 
City: NARBONNE
Country: FRANCE
Vessel Name: 'Snow Mouse.'
Vessel Model: BROOM FLYBRIDGE 42.
Join Date: Apr 2014
Posts: 1,024
If all else fails Google Lancing Marine.co.uk and contact Mike Bellamy. What he doesn't know about Ford 120's you could write on a pinhead.
Those engines are still made in Turkey so no problem with spares.
I hope this helps you.
__________________

Irish Rambler is offline   Reply With Quote
Reply

Tags
fl120 tach sending unit

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off





All times are GMT -5. The time now is 01:49 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2006 - 2012