Reply
 
Thread Tools Display Modes
 
Old 05-17-2015, 12:12 AM   #1
Senior Member
 
HenryD's Avatar
 
City: Heading south for Ft. Myers
Country: USA
Vessel Name: Seven Tenths
Vessel Model: Mirage / Great Harbour 47
Join Date: Dec 2012
Posts: 353
Yanmar Oil Presure & Water Temp Gauges

Hello
I have two Yanmar 4JH3-HTE engines that were installed as a re-power. When this was done, the prior owner or someone made the decision to NOT install the Yanmar dash panel and instead kept the Westerbeke gauges. So on the engine, they installed a RED Westerbeke oil pressure sensor.
Fast forward 9-10 years and now I am having the oil pressure and water temp gauges sometimes read zero, sometimes pegged full over, and sometimes swinging.
I first thought perhaps it's a ground issue but am confused by seeing multiple readings instead of zero or pegged.

Since the Tach, Oil Pressure and Water Temp gauges for both engines are mounted in the dash, I am thinking I should just replace the four sensors. But I have also considered contact one of the guage vendors and installing new senders and gauges.

Suggestions?
Thanks
HenryD is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off





All times are GMT -5. The time now is 12:39 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2006 - 2012