Go Back   Trawler Forum > Maintenance and Systems > Power Systems

Thread Tools Display Modes
Old 06-17-2012, 01:48 PM   #1
Veteran Member
Otisguy's Avatar
City: Bradenton, Florida
Country: United States of America
Vessel Name: Island Spirit
Vessel Model: 1976 Hatteras LRC 48'
Join Date: Dec 2010
Posts: 77
waterpump install on westerbeke 8kw- need help

I am down in Guatemala, Rio Dulce and on my Hatters 48' LRC and my water pump was leaking around the bearings so I assume the seal inside is going bad.
I have a new pump to put in and bunch of extra impellers. I took off pump and noticed old grease with water all mixed in around the water pump bearings.
So question on the new pump do I pack new grease into it?
2nd the part that mount the sea water pump to has bearings in it as well - appears to be a little water in those bearings as well, do I try to dry them off as best as possible and pack them with grease or NO grease at all on any of the bearings?
any help would be great I am right in the middle of the job but safely tied up at Luvi's Marina
Otisguy is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 07:21 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2006 - 2012