Reply
 
Thread Tools Search this Thread Display Modes
 
Old 12-30-2016, 05:39 PM   #1
Senior Member
 
City: Pensacola, FL
Country: USA
Vessel Name: Sea Triscuit
Vessel Model: Transtar 50'
Join Date: Dec 2015
Posts: 202
Question Troubleshooting hydraulic stern thrusters

Our boat has Dickson stern thrusters, two thrusters, powered by a hydraulic pump driven by the Cat 3208 PTO. The thrusters did not work, perhaps due in part to a rusted and leaking filter and loose old belts. While the boat was out of the water I got around to replacing the filter and belts and refilling the reservoir. The thrusters worked when the boat was launched but slowed down and then stopped spinning completely after a few minutes. I have tightened the new belts, topped up the reservoir, and tried again with no luck. I did notice that the light at the stern controls (versus the helm controls where there is no light) no longer lights up as it did when the boat first went back in the water.

My knowledge of the thrusters and how they work is limited and conceptual at best. Other than checking for leaks, what steps can I take to troubleshoot? Is there a bleed valve somewhere to let any additional air out of the system? Is there a typical way these are wired and what should I be checking? I welcome any help and please don't assume I know anything! Thanks!
__________________
Advertisement

Panhandler is offline   Reply With Quote
Old 12-30-2016, 06:26 PM   #2
Senior Member
 
City: Anacortes
Country: United States
Join Date: Mar 2016
Posts: 236
The light, or lack of, is likely a clue. Your dash switch controls solenoids which switch fluid direction, there may also be an electric clutch at the pump so the pump doesn't run full time. The system has 2 sides hydraulic and electric. The hydraulic side is pretty simple and should be durable. My bet is on the electric side. Time to start doing some detective work.
__________________

sean9c is offline   Reply With Quote
Old 12-30-2016, 09:00 PM   #3
Guru
 
Capt.Bill11's Avatar
 
City: Sarasota/Ft. Lauderdale
Country: USA
Join Date: Apr 2014
Posts: 5,436
Do you have any gauges that show the hydraulic pressure in the system?
Capt.Bill11 is offline   Reply With Quote
Old 12-31-2016, 08:25 AM   #4
Senior Member
 
City: Pensacola, FL
Country: USA
Vessel Name: Sea Triscuit
Vessel Model: Transtar 50'
Join Date: Dec 2015
Posts: 202
Sean9c, thanks. That's along the lines of what I'm thinking as well.

Capt.Bill11, there is a gauge but it hasn't moved in a year so I have doubts about its accuracy.
Panhandler is offline   Reply With Quote
Old 12-31-2016, 08:51 AM   #5
Guru
 
jleonard's Avatar
 
Join Date: Jun 2008
Posts: 3,481
Dickson still has a web site. Why not contact them and ask for a set of installation instructions? That will give you the tool to troubleshoot.
__________________
Jay Leonard
Attitude Adjustment
40 Albin
Mystic,Ct. /New Port Richey,Fl
jleonard is offline   Reply With Quote
Old 01-02-2017, 08:45 AM   #6
Senior Member
 
City: Pensacola, FL
Country: USA
Vessel Name: Sea Triscuit
Vessel Model: Transtar 50'
Join Date: Dec 2015
Posts: 202
Quote:
Originally Posted by jleonard View Post
Dickson still has a web site. Why not contact them and ask for a set of installation instructions? That will give you the tool to troubleshoot.
Thanks, jleonard. I did contact them but didn't think to ask for the installation instructions. I'll do that.
__________________

Panhandler is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off





All times are GMT -5. The time now is 12:03 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2006 - 2012
×