Reply
 
Thread Tools Search this Thread Display Modes
 
Old 12-14-2018, 05:31 PM   #1
Newbie
 
City: Courtenay
Country: canada
Join Date: Sep 2018
Posts: 1
Stern Thruster not working correctly

I've got a 2013 Ranger Tug R-25sc and I have a problem with the stern thruster as it works only in one direction periodically. I've contacted Ranger Tug and they are saying it could be a electrical connection or solonoid needs to be replaced. Of course the local marine shop says I need to replace the thruster.
Has anyone had a similar problem or fix with this thruster? The thruster is a Side Power
TIA
__________________
Advertisement

ronv99 is offline   Reply With Quote
Old 12-14-2018, 05:37 PM   #2
Guru
 
Comodave's Avatar
 
City: Au Gres, MI
Country: US
Vessel Name: Never Say Never
Vessel Model: President 41 DC
Join Date: Jul 2015
Posts: 5,462
If it works in one direction, I would suspect a the solenoid or control wires or joystick. Have you talked to Imtra for help in troubleshooting? I would work with them instead of Ranger. I would not jump into replacing the thruster if you have not trouble shot the problem.
__________________

Comodave is offline   Reply With Quote
Old 12-14-2018, 05:46 PM   #3
Guru
 
Northern Spy's Avatar
 
City: Powell River, BC
Country: Canada
Vessel Name: Northern Spy
Vessel Model: Nordic Tug 26
Join Date: Feb 2012
Posts: 3,017
Try this troubleshooting guide:

https://www.imtra.com/Collateral/Doc...e_with_IPC.pdf

I keep this on my phone and iPad for if/when the inevitable need arises.

Imtra provides great support via phone or email.

Could also contact Port Boat House...
Northern Spy is offline   Reply With Quote
Old 12-14-2018, 05:50 PM   #4
Guru
 
HopCar's Avatar
 
City: Miami Florida
Vessel Name: Possum
Vessel Model: Ellis 28
Join Date: Aug 2011
Posts: 4,369
Id contact Imtra Marine. They are the US distributor for Side Power. They are really nice folks and will try o help you. https://www.imtra.com/contact-us.htm

My bet would be on a bad solenoid as well. At least thats the first thing Id check.
__________________
Parks Masterson
HopCar is offline   Reply With Quote
Old 12-14-2018, 08:15 PM   #5
Guru
 
jimisbell's Avatar
 
City: Ingleside-On-The-Bay, Texas
Country: USA
Vessel Name: Papillon
Vessel Model: 1978 Mainship 34 Trawler #95
Join Date: Jan 2018
Posts: 605
You said "periodically" If that means "intermittently" then I would bet 100 to one its just dirty contacts in a relay that can be cleaned at no cost but labor.
jimisbell is offline   Reply With Quote
Old 12-14-2018, 10:33 PM   #6
Guru
 
78puget-trawler's Avatar
 
City: LaConner
Country: USA
Vessel Model: 34' CHB
Join Date: Apr 2016
Posts: 1,073
My dad was fond of saying about such things,, "its got an intermittent in it, sometimes it works and sometimes it don't".
__________________

78puget-trawler is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off





All times are GMT -5. The time now is 07:18 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2006 - 2012
×