Reply
 
Thread Tools Display Modes
 
Old 06-04-2013, 04:25 PM   #1
Senior Member
 
City: Madisonville
Country: USA
Vessel Name: Nirvana
Vessel Model: 41' Litton
Join Date: Feb 2011
Posts: 142
Angry Onan Raw Circulation

What am I missing? The raw water cooling on my Onan 7.5 MDJE has stopped AGAIN. Usually it needs repriming, impeller, etc. Not this time. It will pump water to the level of the HE but no farther. I disconnected the hoses; I can blow through the HX & blow/suck from the seacock. When the gen is running it will slowly pump water to within an inch of the HX an no farther (I've got a clear hose here). I installed new impeller; watched it spin with cover off; checked the HX tubes for blockage, etc. What's going on?!!!
__________________
Advertisement

Dixie Life is offline   Reply With Quote
Old 06-04-2013, 06:20 PM   #2
Guru
 
City: Carefree, Arizona
Country: usa
Vessel Name: sunchaser V
Vessel Model: DeFever 48
Join Date: Apr 2008
Posts: 6,369
Do you have a water lift muffler? If so pull the feed hose off it to see if water comes out when you start the genset.

How old is the genset?
__________________

sunchaser is offline   Reply With Quote
Old 06-05-2013, 05:04 PM   #3
JAT
Guru
 
JAT's Avatar
 
Country: US
Vessel Name: Just a Tinch
Vessel Model: Gulfstar 44 MC
Join Date: Jan 2010
Posts: 595
Have you made certain that there is absolutely nothing restricting the water coming in at the seacock? If you changed the impeller.... and its not helping....that begs two questions: 1. What kind of shape is the impeller cover plate in, as in does it provide a good seal to the side of the impeller when its on, and 2... Is the cam excessively worn in the pump?
JAT is offline   Reply With Quote
Old 06-05-2013, 09:31 PM   #4
Guru
 
BobH's Avatar
 
City: Montgomery, TX
Country: USA
Vessel Model: None, but looking
Join Date: Feb 2012
Posts: 778
Jellyfish in the seacock?

Bob
BobH is offline   Reply With Quote
Old 06-14-2013, 11:39 PM   #5
Guru
 
Edelweiss's Avatar
 
City: PNW
Country: USA
Vessel Model: 1976 Californian Tricabin LRC
Join Date: May 2011
Posts: 1,834
That begs two questions: 1. What kind of shape is the impeller cover plate in, as in does it provide a good seal to the side of the impeller when its on, and 2... Is the cam excessively worn in the pump?[/QUOTE]
-----------------------------------------------------
Yes, be sure and check those two clearances, very critical wear points for a rotary pump. The stock MDJE raw water pump is gear driven with a fairly long shaft and single bearing. The shaft and bearing are a common fail point. If the bearing has excessive play that will also stop it from pumping.

That Onan pump was the nemesis of my life for the last 30+ years failing me many times. I finally replaced it 3 - 4 years ago with a belt driven Jabsco brass pedestal mount pump. The platform that the pedestal fresh water pump is mounted on, has plenty of room for another pump. You just have to measure for the proper belt length. Be sure and fashon a cover plate and gasket to cover the power take off port on the generator. Blows oil all over hell if it's not covered.

p.s. If you haven't priced the original parts and replacement Onan pump, you will be in for a surprise. It's through the roof, if you can even find it. I could buy 3 or 4 Jabsco pumps for what they want for the original. Plus the pedestal pump is a better design and has performed flawlessly ever since.
__________________
Larry B
Careful . . .I Have a Generator and I'm not afraid to use it !
Edelweiss is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off





All times are GMT -5. The time now is 07:57 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2006 - 2012