Reply
 
Thread Tools Display Modes
 
Old 08-12-2012, 05:00 PM   #1
Guru
 
jleonard's Avatar
 
Join Date: Jun 2008
Posts: 2,740
Generator troubleshooting question

I have a Westerbeke 4.4 kw diesel, circa 1983, with 2100 plus hours on it.
Yesterday it started to make the lights "flicker every minute or so.
Watching the voltmeter (analog) it is dropping from 115 to "about" 105 or so and when it does the lights flicker. Genny is NOT overloaded, I only had 2 lights on and the battery chargers. Water heater had already finished 1/2 hour prior to the issue.

Engine seems like it's running smooth. I cannot hear the engine dropping any rpm when the voltage blips.

Brushes?
__________________
Advertisement

__________________
Jay Leonard
Attitude Adjustment
40 Albin
Mystic,Ct. /New Port Richey,Fl
jleonard is offline   Reply With Quote
Old 08-13-2012, 09:46 AM   #2
Member
 
Join Date: Mar 2012
Posts: 6
If the voltage is dropping and the RPM/Hz is staying at 60 or so, then I'd suspect the voltage regulator. Look for loose/green wires first. After that, maybe brushes.

Wes
marine nut is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off





All times are GMT -5. The time now is 06:47 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2006 - 2012