Reply
 
Thread Tools Display Modes
 
Old 06-16-2014, 05:41 PM   #1
Guru
 
City: Full Time Cruising East Coast
Country: USA
Vessel Name: Meridian
Vessel Model: Krogen-42
Join Date: Aug 2011
Posts: 755
FL 120 heat exchanger failure?

Check my ER this today and found the external overflow tank was full and had spilled about a quart into the bucket that was underneath it. Since the system is pressurized I expected any loss of coolant would be on the low pressure side. The only place I see this failing is the heat exchanger. Any other ideas?
__________________
Advertisement

__________________
-------------------------
Terry
Meridian
KK-42097
meridian is offline   Reply With Quote
Old 06-16-2014, 05:52 PM   #2
TF Site Team
 
Larry M's Avatar
 
City: JAX, FL
Country: USA
Vessel Name: Hobo
Vessel Model: Krogen 42-120
Join Date: Nov 2008
Posts: 5,737
It could easily be that the cap failed allowing coolant out into the overflow.
__________________

Larry M is offline   Reply With Quote
Old 06-16-2014, 05:59 PM   #3
Guru
 
City: Full Time Cruising East Coast
Country: USA
Vessel Name: Meridian
Vessel Model: Krogen-42
Join Date: Aug 2011
Posts: 755
I don't think the cap failed as the block is still filled to the top. Just a thought that it could bee the hot water heater but that would be a long shot. I haven't heard the water pump cycling
__________________
-------------------------
Terry
Meridian
KK-42097
meridian is offline   Reply With Quote
Old 06-16-2014, 06:12 PM   #4
TF Site Team
 
Larry M's Avatar
 
City: JAX, FL
Country: USA
Vessel Name: Hobo
Vessel Model: Krogen 42-120
Join Date: Nov 2008
Posts: 5,737
Pressure test your system.
Larry M is offline   Reply With Quote
Old 06-16-2014, 07:07 PM   #5
Guru
 
City: Full Time Cruising East Coast
Country: USA
Vessel Name: Meridian
Vessel Model: Krogen-42
Join Date: Aug 2011
Posts: 755
Great idea. I can borrow a tester from Advance Auto for free.
__________________
-------------------------
Terry
Meridian
KK-42097
meridian is offline   Reply With Quote
Old 06-17-2014, 08:26 PM   #6
Guru
 
City: Full Time Cruising East Coast
Country: USA
Vessel Name: Meridian
Vessel Model: Krogen-42
Join Date: Aug 2011
Posts: 755
I called and checked with 4 national chain auto stores. All said they had a tester. When I got to each one, they were broken, couldn't find it, or never had it. After talking to Brian at ADC he agreed that the unit had failed.
__________________
-------------------------
Terry
Meridian
KK-42097
meridian is offline   Reply With Quote
Old 06-17-2014, 09:54 PM   #7
Guru
 
Capt.Bill11's Avatar
 
City: Sarasota/Ft. Lauderdale
Country: USA
Join Date: Apr 2014
Posts: 5,422
The heat exchanger failed? Have you had it cleaned and pressure tested yet?
Capt.Bill11 is offline   Reply With Quote
Old 06-18-2014, 02:19 AM   #8
Guru
 
Xsbank's Avatar
 
City: Pender Harbour, BC
Country: Canada
Vessel Name: Gwaii Haanas
Vessel Model: Vancouver Shipyards Custom Aluminum 52
Join Date: Sep 2013
Posts: 2,447
Have you bled the bleeder on the top of the block?
__________________

__________________
Don't believe everything that you think.
Xsbank is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off





All times are GMT -5. The time now is 01:40 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2006 - 2012