Go Back   Trawler Forum > Trawler Forum > Welcome Mat

Thread Tools Display Modes
Old 03-07-2016, 07:35 AM   #1
City: Vero Beach
Country: USA
Vessel Name: Etoiles
Vessel Model: GB36
Join Date: Feb 2016
Posts: 6
New member Vero/Maine

Just closed on a very neglected GB36 Classic. Great to visit this site for all my maintenance issues. On my ride from Palm Beach to Ft Pierce yesterday looked at the bilge and saw water rushing in. So slowed to neutral and water stopped. Started up again and everything ok, water had been come from port side. I think the T&P valve on the water heater blew for a moment from the engine heating up the tank and the expansion tank either not enough or has failed. Any thoughts.

Gearhead is offline   Reply With Quote
Old 03-07-2016, 07:36 AM   #2
RT Firefly's Avatar
City: Slicker?
Country: Bumpkin?
Join Date: Oct 2007
Posts: 7,858
Welcome aboard.

RT Firefly is offline   Reply With Quote
Old 03-07-2016, 07:39 AM   #3
twistedtree's Avatar
City: Gloucester, MA
Country: USA
Join Date: Jan 2013
Posts: 2,050
Was it fresh water? Was it hot? I'd first want to conform with certainty where it's coming from, but maybe you already did that?
twistedtree is offline   Reply With Quote
Old 03-07-2016, 08:51 AM   #4
Capt.Bill11's Avatar
City: Sarasota/Ft. Lauderdale
Country: USA
Join Date: Apr 2014
Posts: 4,551
Originally Posted by Gearhead View Post
Any thoughts.
To little information.
Capt.Bill11 is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 02:38 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2006 - 2012