Reply
 
Thread Tools Display Modes
 
Old 05-16-2018, 11:48 AM   #1
Member
 
City: Decatur, AL
Country: United States
Vessel Name: FELLOWSHIP
Vessel Model: CARVER SANTEGO 3467, 41'
Join Date: May 2018
Posts: 5
Unhappy Seawolf 520 Windlass problem

I have a Seawolf 520 Windlass on my Carver Santego since i purchased the boat a few years ago. Never had a problem anchoring most every weekend, until this past weekend when I proceeded to drop anchor and the Clutch Nut was very difficult to turn clockwise. In the past just a quarter turn or so and it would drop, and after the anchor bottomed, it had always felt like if i kept turning, with just using two fingers turning clockwise the nut would come right off. But not this time! And when I proceeded to turn the clutch nut counterclock wise to prepare to retrieve the anchor, it was like it was frozen in place??? When i stepped on the footswitch, I had elect to the windlass because the drum and the clutch nut would turn, but gipsy would not try to pull the chain up, like the clutch nut was locked down and wouldn't turn either way??? I don't know why, all of a sudden, I cant turn the Clutch nut at all???
__________________
Advertisement

fsgjdsmith is offline   Reply With Quote
Old 05-16-2018, 02:33 PM   #2
Guru
 
City: Westerly, RI
Country: USA
Vessel Name: N/A
Vessel Model: 1999 Mainship 350 Trawler
Join Date: Jan 2014
Posts: 697
Welcome aboard fsgjdsmith!!!!

Moved from "How To Use The Forum, Site News & Account Concerns" to "Anchors and Anchoring".

Have you disassembled the unit for inspection and servicing? Corrosion and gunk build-up could be coming into play. I'd start by disassembling, cleaning, inspecting and lubricating. If there is a problem, it will become apparent.

There are fewer parts than you think in there.
__________________

Shrew is offline   Reply With Quote
Old 05-16-2018, 02:42 PM   #3
Member
 
City: Decatur, AL
Country: United States
Vessel Name: FELLOWSHIP
Vessel Model: CARVER SANTEGO 3467, 41'
Join Date: May 2018
Posts: 5
Thanks

I found a manual for it today. My boat is at a marina about an hour and a half away. I will do that for the first time this weekend. I've never had an Electric Windlass before, so i was a little intimidated at the thought of taking it all apart, actually the intimidation is trying to put it back together correctly. But I thought maybe there was some quick solution as to the reason why all of a sudden in one day, it went from working flawlessly to NOT WORKING??? So I will get really familiar with it this weekend. Thanks again.
fsgjdsmith is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off





All times are GMT -5. The time now is 02:35 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2006 - 2012