Thread Tools Display Modes
Old 07-28-2012, 08:29 PM   #1
Senior Member
Boydster's Avatar
City: Squamish, B.C.
Country: Canada
Vessel Name: Change of Heart
Vessel Model: Grand Banks 42
Join Date: Mar 2011
Posts: 214
Freedom 25 issues

Finally got our Onan gennie back up and running with a lot of online help from "bobofthenorth"...Thanks Bob, but as usual with boats another problem has arisen.
I'm getting a fault light on the remote monitor for our Freedom 25 charger/inverter about 20 seconds after putting it in charge mode. This happens whether we're on shore power or generator. I checked the inverter and none of the reset/breakers have been tripped and up until last weekend it has worked flawlessly. For what its' worth, the batteries are 6, 6 volt golf carts at 350ah each and are in decent condition despite being five years old. Don't even know where to begin looking...suggestions? Considering the age of this unit and the fact that it is no longer supported perhaps its time to replace it? - Boyd
Everything on your boat is just don't know about it yet.
Boydster is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 12:22 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2006 - 2012