Reply
 
Thread Tools Display Modes
 
Old 06-27-2012, 12:55 PM   #1
Veteran Member
 
Third-Reef's Avatar
 
City: Santa Barbara, California
Vessel Name: Fleur De Lys
Vessel Model: 1988 Nova 36 Sundeck
Join Date: Dec 2011
Posts: 56
Comnav Autopilot, backup battery replacement?

I have a Comnav 1420 auto pilot that works fine every time i go thtough the setup procedure. However after being powered off for several days it needs to be set up again. The manual says it needs "to be returned for service". I am pretty sure it needs the memory backup battery replaced. Anybody ever done this? Next time i am at the boat with some time i will thake the cove off and look for said battery
__________________
Advertisement

Third-Reef is offline   Reply With Quote
Old 06-27-2012, 01:39 PM   #2
Senior Member
 
bshanafelt's Avatar
 
City: Seattle, WA
Vessel Name: Isobel K
Vessel Model: 37' Custom Pilothouse
Join Date: Oct 2007
Posts: 289
Just call Comnav - Satish will walk you through just about any maint. repair you need
__________________

bshanafelt is offline   Reply With Quote
Old 06-27-2012, 07:31 PM   #3
Senior Member
 
Vyndance's Avatar
 
City: Ventura, CA
Country: USA
Vessel Name: Vyndance
Vessel Model: 48 Californian CP
Join Date: Aug 2010
Posts: 154
It is not exactly cover off it's slide out PCB. If you did not do the install and have not before had it apart I would take the above advice and call Satish.
Vyndance is offline   Reply With Quote
Old 06-28-2012, 01:38 AM   #4
Veteran Member
 
Third-Reef's Avatar
 
City: Santa Barbara, California
Vessel Name: Fleur De Lys
Vessel Model: 1988 Nova 36 Sundeck
Join Date: Dec 2011
Posts: 56
I called and the battey is actually inside the chip. $125 for the chip and $75 labor to replace it, not bad for service charges on a 15 year old system. I need to check some things first, i may not have been operating it properly and actually causing it to reset when i turn it on. Very helpfull company. They gave me info in the rudder angle indicator i wanted to install. Turns out it will oly indicate rudder angle while the auto pilot is operating, not while i am say docking. Glad i did not wast the money on that one. Thanks for the input.
Third-Reef is offline   Reply With Quote
Old 06-28-2012, 10:55 AM   #5
Senior Member
 
Vyndance's Avatar
 
City: Ventura, CA
Country: USA
Vessel Name: Vyndance
Vessel Model: 48 Californian CP
Join Date: Aug 2010
Posts: 154
The unit only has to be powered on for the RAI to work. Not engaged. Same with the heading sensor.
Vyndance is offline   Reply With Quote
Old 06-28-2012, 11:38 AM   #6
Veteran Member
 
Third-Reef's Avatar
 
City: Santa Barbara, California
Vessel Name: Fleur De Lys
Vessel Model: 1988 Nova 36 Sundeck
Join Date: Dec 2011
Posts: 56
The tech support guy, Om was his name, spicifically told me it had to be in pilot or nav mode. He said the 1420 did not have standby mode, it was basically ON or OFF and in the ON condition it could be in nav or pilot mode. He suggested that i get a standalone RAI unit if i wanted that function.
__________________

Third-Reef is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off





All times are GMT -5. The time now is 03:51 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2006 - 2012