Reply
 
Thread Tools Display Modes
 
Old 03-25-2013, 09:02 PM   #1
Hospitality Officer
 
Andy G's Avatar
 
City: Pittwater
Country: Australia
Vessel Name: Sarawana
Vessel Model: IG 36 Quad Cabin
Join Date: Sep 2010
Posts: 1,557
Tecma's revisited

Here's a question for you intrepid Tecma owners. My aft loo occasionally does not shut down on the evacuate cycle and will keep running till it trips the fuse or I manually shut it down.

Normally after a few minutes I can reset the unit(sometimes quite a bit longer than a few seconds though). In all other respects the loo is working as designed. Has anyone else come across this problem, suggestions how to fix appreciated.
__________________
Advertisement

Andy G is offline   Reply With Quote
Old 03-26-2013, 09:19 AM   #2
Guru
 
Join Date: Oct 2007
Posts: 733
Our Tecma has performed flawlessly with no repairs needed for the last 8 years of our ownership. It is original 1999 equipment. Only thought I have is to check water pressure feeding toilet. Otherwise I would look for a faulty/sticking switch mechanism. I would guess the switch would simply be a timer mechanism.
Chrisjs is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off





All times are GMT -5. The time now is 02:49 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2006 - 2012