Reply
 
Thread Tools Display Modes
 
Old 06-17-2015, 02:28 PM   #1
Veteran Member
 
City: Muskegon, MI
Country: USA
Vessel Name: Knot Salted
Vessel Model: 1981 Californian 34 LRC
Join Date: Mar 2015
Posts: 55
Raytheon SL70

Hello,

This old unit performed flawlessly when we really needed it on our maiden trip from Sandusky around the lower peninsula of Michigan four weeks ago. lots of fog! Last weekend, I fired it up just to check it, and got the normal screen, but no targets displayed, and there were plenty of boats all around. Messed with gain and ranges, tried connections at the display - restarted.. --no targets.

Any thoughts? Thanks!
__________________
Advertisement

schaefferoil is offline   Reply With Quote
Old 06-17-2015, 03:51 PM   #2
Enigma
 
RT Firefly's Avatar
 
City: Slicker?
Country: Bumpkin?
Join Date: Oct 2007
Posts: 9,994
Greetings,
Welcome aboard.
__________________

__________________
RTF
RT Firefly is offline   Reply With Quote
Old 06-17-2015, 09:51 PM   #3
Veteran Member
 
City: Maryville, TN
Country: USA
Vessel Name: malu lani
Vessel Model: Albin 27 FC
Join Date: Apr 2014
Posts: 77
I have the same unit. If you'll open up the radome by removing the screws under the dome cover, you'll see that the power wires are simply slipped into the terminals and secured by a screw. These can come loose and the radome doesn't work. It's an easy check. Ben
tego is offline   Reply With Quote
Old 06-18-2015, 09:39 AM   #4
Veteran Member
 
City: Muskegon, MI
Country: USA
Vessel Name: Knot Salted
Vessel Model: 1981 Californian 34 LRC
Join Date: Mar 2015
Posts: 55
Thanks!

I will check that out this weekend. Much appreciated Ben.

--Jim
schaefferoil is offline   Reply With Quote
Old 06-23-2015, 05:00 PM   #5
Veteran Member
 
City: Muskegon, MI
Country: USA
Vessel Name: Knot Salted
Vessel Model: 1981 Californian 34 LRC
Join Date: Mar 2015
Posts: 55
Ben,

Thanks!

You suggested popping open the radome to check connections.

when I did, I found that the motor was turning, but the array was not.

Wiped off the 'belt' (lg o-ring) and used my wife's emery board on the well polished motor pulley.

Works like new.
schaefferoil is offline   Reply With Quote
Old 06-23-2015, 09:44 PM   #6
Veteran Member
 
City: Maryville, TN
Country: USA
Vessel Name: malu lani
Vessel Model: Albin 27 FC
Join Date: Apr 2014
Posts: 77
Ain't it nice when something is simple? and cheap! Great job. Ben
tego is offline   Reply With Quote
Old 06-24-2015, 08:13 AM   #7
Veteran Member
 
City: Muskegon, MI
Country: USA
Vessel Name: Knot Salted
Vessel Model: 1981 Californian 34 LRC
Join Date: Mar 2015
Posts: 55
Sure is.
__________________

schaefferoil is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off





All times are GMT -5. The time now is 02:51 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2006 - 2012