Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-04-2018, 10:37 AM   #1
Guru
 
djmarchand's Avatar
 
City: Litchfield, Ct/Punta Gorda, Fl
Country: USA
Join Date: Aug 2012
Posts: 3,527
Carriage return, line feed settings

This problem isn't specific to trawler forums but TF is the most prevalent one I use with this problem. For the last few months my posts have a double line feed in them every time I do a paragraph break with an "enter" key. I suspect that my Windows 10 system is now issuing a carriage return and line feed which is processed by the forum as two line feeds. I need to be able to switch it to issue just a single carriage return when i press the enter key.


I have fixed this in the past with older windows versions, but after googling the symptom I can't find the fix again. As I recall it is a simple control key sequence that switches to a single carriage return but I can't find it.


Can you help me with this?


David
__________________
Advertisement

djmarchand is offline   Reply With Quote
Old 08-04-2018, 11:32 AM   #2
Guru
 
HeadMistress's Avatar


 
City: AR
Country: USA
Join Date: Jul 2009
Posts: 1,377
For the last few months my posts have a double line feed in them every time I do a paragraph break with an "enter" key. I suspect that my Windows 10 system is now issuing a carriage return and line feed which is processed by the forum as two line feeds.

I have the same problem. Didn't think to equate it with the brand new computer I've been running for less than a month till I read your post, but that is when it started. Old one was running Win 10 Home, new one is running Win 10 Pro. Only solution I've been able to find is to immediately edit my posts and backspace out the extra lines between paragraphs.

(You have to be at least as old as I am to know the term "carriage return." )

--Peggie
__________________

__________________
2018 Peggie Hall
Specializing in marine sanitation since '87.
Author "The NEW Get Rid of Boat Odors"
HeadMistress is offline   Reply With Quote
Old 08-04-2018, 11:49 AM   #3
Senior Member
 
Portage_Bay's Avatar
 
City: Seattle
Country: United States
Vessel Model: Tollycraft 40 Tri-cabin
Join Date: Oct 2015
Posts: 234
I'm having the same problem. I doubt it's related to your operating system(s), I'm running Win 7 on one laptop and Linux on the other.

I resort to the 'brute force' fix. Preview my post then back out one of the CL/LF between paragraphs.
Portage_Bay is offline   Reply With Quote
Old 08-06-2018, 09:11 AM   #4
TF Site Team
 
City: Westerly, RI
Country: USA
Vessel Name: N/A
Vessel Model: 1999 Mainship 350 Trawler
Join Date: Jan 2014
Posts: 896
Interesting. Windows has used <CR><LF> for many, many years. Unix uses <LF>. This causes issues when you attempt to import a file written in Windows into a Unix system. Frequently Unix sees one and you get a bunch of 'junk' for the <CR> at the end of each line. This really causes issues if the file is a script. Under such circumstances, I would run 'dos2unix' against the file to clear the <CR> from the lines. Obviously, you can't do this in your posts.

I'm running Windows 10 and don't have this issue. I'm going to assume that the back-end servers hosting VBulliten are Apache or Tomcat on Linux.

I'll dig around a little and see if this is a known issue.
Shrew is offline   Reply With Quote
Old 08-06-2018, 10:40 AM   #5
Guru
 
djmarchand's Avatar
 
City: Litchfield, Ct/Punta Gorda, Fl
Country: USA
Join Date: Aug 2012
Posts: 3,527
Thanks Shrew. I am aware of the Unix/Windows CR/LF disconnect. Did something change in the forum software maybe 2-3 months ago. All of my forums that use this SW have the same problem and it started at about the same time. I assumed it was a Windows upgrade or something that changed how Windows processes CRs on my end. But maybe it is the forum SW.


David
djmarchand is offline   Reply With Quote
Old 08-06-2018, 10:51 AM   #6
Guru
 
twistedtree's Avatar
 
City: Gloucester, MA
Country: USA
Join Date: Jan 2013
Posts: 3,782
This is just a guess, but I have seen similar issues before....... Id suspect its in the translation from the text window that you type your response in, into HTML for the web display/server. The probably changed in VBulletin and everyone picked it up.
__________________
www.MVTanglewood.com
twistedtree is offline   Reply With Quote
Old 08-06-2018, 11:15 AM   #7
TF Site Team
 
City: Westerly, RI
Country: USA
Vessel Name: N/A
Vessel Model: 1999 Mainship 350 Trawler
Join Date: Jan 2014
Posts: 896
David,


Which web browser are you using? (e.g. MS Internet Explorer, MS Edge, Chrome, Firefox). I wonder if this is browser specific. I've tried in both Chrome and IE and cannot reproduce the issue. I'm going to try in MS Edge and Firefox and see if I can reproduce the behavior.
Shrew is offline   Reply With Quote
Old 08-06-2018, 02:21 PM   #8
Guru
 
djmarchand's Avatar
 
City: Litchfield, Ct/Punta Gorda, Fl
Country: USA
Join Date: Aug 2012
Posts: 3,527
I have been using Firefox, but I switched to Edge for this post.

How is it working. Extra space?

David

Edit: Well Edge solved the problem. So it is Firefox related. I have looked by can't find a Firefox setting that addresses the problem.

Anyone?

David
djmarchand is offline   Reply With Quote
Old 08-06-2018, 02:25 PM   #9
Guru
 
twistedtree's Avatar
 
City: Gloucester, MA
Country: USA
Join Date: Jan 2013
Posts: 3,782
No extra space.


I'm typing this with Firefox.


Extra space?
__________________
www.MVTanglewood.com
twistedtree is offline   Reply With Quote
Old 08-06-2018, 06:26 PM   #10
TF Site Team
 
Janet H's Avatar
 
City: Inland NW
Country: USA
Vessel Name: Pacifica
Vessel Model: Cape Dory
Join Date: Jan 2012
Posts: 1,809
Every few years one browser or another has an update and we have this issue. This year, it's Firefox. Typically they will release an update to the browser and the issue will be fixed. until then your choices are:

1. Use a browser other than Firefox.
2. Change your account settings at the forum to use the Standard Editor Toolbar instead of the WYSIWYG full editor.

You can do that here: https://www.trawlerforum.com/forums/...do=editoptions

Scroll and hit save after... Note that making this change will result in a simplified reply editor.
Janet H is offline   Reply With Quote
Old 08-06-2018, 09:32 PM   #11
Guru
 
djmarchand's Avatar
 
City: Litchfield, Ct/Punta Gorda, Fl
Country: USA
Join Date: Aug 2012
Posts: 3,527
Janet:

Thanks for your sage advice. I think I will stick with Firefox and use the wysiwyg settings and hope that Firefox fixes it soon.

BTW, this post is was done with Chrome on my iPad which is why no extre LFs.

David
djmarchand is offline   Reply With Quote
Old 08-06-2018, 09:43 PM   #12
Guru
 
dhays's Avatar
 
City: Gig Harbor
Country: United States
Vessel Name: Kinship
Vessel Model: North Pacific 43
Join Date: May 2015
Posts: 6,535
Fwiw, for those with the extra line in your posts, I think I can read your posts despite the inordinate amount of extra time that it takes to glance down that extra line.
__________________

__________________
Regards,

Dave
SPOT page
dhays is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off





All times are GMT -5. The time now is 03:02 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2006 - 2012