Go Back   Trawler Forum > Trawler Builders Forums > Marlow - Mainship

Thread Tools Display Modes
Old 01-04-2012, 07:57 PM   #1
Join Date: Jan 2012
Posts: 1
Mainship bilge pump float switches

I have owned my 1999 350 Mainship for 4 years, and recently got some water in the aft bilge area. It did not pump out until I hit the switch on the panel. I got a 5 gallon bucket and dumped it in the mid and forward bilge sumps, with the same result!

All 3 "SURE BAIL" float switches had failed.

Just an "FYI"!

TJBENZ is offline   Reply With Quote
Old 01-04-2012, 09:37 PM   #2
Carey's Avatar
City: Bellingham, WA
Country: USA
Vessel Name: Happy Destiny
Vessel Model: Custom Lobster Yacht
Join Date: Oct 2007
Posts: 1,101
RE: Mainship bilge pump float switches

Three at once seems unlikely. I would suspect something else.

Carey is offline   Reply With Quote
Old 01-05-2012, 09:43 AM   #3
jleonard's Avatar
Join Date: Jun 2008
Posts: 2,407
RE: Mainship bilge pump float switches

Also might not be a Mainship specific problem. I would suggest you post this in a more generic topic area for better exposure.
jleonard is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Bad bilge pump? Keith Other Trawler Systems 17 07-31-2014 06:26 PM
Bilge float switch Forkliftt Other Trawler Systems 103 12-14-2012 12:01 AM
Bilge Pump Advice Tom.B General Maintenance 10 02-14-2012 11:36 AM
Using a float switch to turn a pump off timjet General Maintenance 30 10-20-2011 05:49 PM
Bilge pump Fotoman General Discussion 3 06-15-2010 09:32 AM

All times are GMT -5. The time now is 05:10 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2006 - 2012